Jump to content

Simplicity
FORUMS

Sign in to follow this  
Jsteeze

Simplicity Client Issue Fixes

Recommended Posts

Jsteeze    24

005b3e1c7704f69df63f24fb469e9417_nav-log         trserrf.png          005b3e1c7704f69df63f24fb469e9417_nav-log 

Client stuck on loading screen?

If your client is stuck on the loading screen, try clearing your cache.

 

Finding Cache For Windows users:

Go to C:\Users\(Enter your username)...Once you are there you should be able to see two folders names. "SimplicityCache and .Simplicity.Delete both! 

Alternatively, you can use the cache reset tool on the SimplicityPS forums. This could also mean that you might not have a stable connection which will fail to download the cache properly.

(After you have deleted the Cache make sure to download the  Client+)

Finding Cache For Mac Users:

 Open spotlight search

Enter \Users\(Insert your Mac username here) - Once you are there you should be able to see a folder named ".SimplicityCache and .Simplicity" - Delete both.  (Make sure your Client is closed before you delete the Cache)

• If you are not able to see these folders that means they are hidden, to view them you need to press; Shift + Command + 

(After you have deleted the Cache make sure to download the Client+)

file

 

Client closing after loading 8/8 on startup?

If your client is closing after loading 8/8 the startup, this indicates that you have JDK installed and not JRE or both installed. If this is the case, uninstall JDK and install the latest JRE version from oracles website. Once the you have JRE installed, relaunch the client and it should start loading fully.

file

 

HD 117 not working?

If HD 117 is not working for you, update your JRE version of Java and install both the 32bit and the 64-bit JRE together onto your machine. Turn on HD 117 plugin through the runelite settings and close and reopen the client. 

file

 

Client showing as .RAR not .JAR file?
If the client is not opening as a .JAR and it is instead loading up and a .RAR file, this usually means that you don’t have JRE installed onto your machine. You’ll need to download the latest JRE version from oracles website. Then retry to open the client. 

If you have JRE installed onto your machine but still opens as a .RAR file, Then run Jarfix OR you can right click the client .RAR and ‘Open With’ > ‘Java™ Platform SE Binary’.

file

 

Client missing textures/not working properly after the update?
If the client is missing textures/not working properly after the update, Clear your Cache to the game and redownload a fresh cache when you reopen the client. This will update any missing textures.  

file

 

Walls missing from bank and other buildings?
Go to Runelite HD (117) Settings and change the level of detail to High. If already at high, change to full.

If you log in and can only see a black screen but can type in the chat this normally means that you tried to log into the server but your connection has been interrupted when loading into the game. The way to fix this is to ask a staff member to move your account ::home and kick. Once you have been kicked, if this still doesn’t work ask a staff member to move your account ::home and have it killed. FOR HCIM AND REALISM PLAYERS PLEASE! LET THE STAFF MEMBER KNOW OF YOUR ACCOUNT TYPE AS DIFFERENT METHODS MAY BE USED.

 

Jarfix fixes the jar file association on Windows

file

 

Client won't run? Here Is a few steps to fix the issue

Make sure you have Java  downloaded

Still not working? Create a path

Screenshot 2023-11-15 205847      1.jpg

 

 

Screenshot 2023-11-15 205941      2.jpg

 

 

Screenshot 2023-11-15 211044 3.jpg

 

 

Screenshot 2023-11-15 210410   4.jpg

C:\Program Files\Java\jre.8.0_171\bin

C:\Program Files (x86)\Java\jre1.8.0_171\bin

file

 

Client runs the launcher but doesn't open the game - What to do?

First you will need to check to see if you have the correct java installed.  You can do this by accessing the 'Apps & features' option in the control panel.  Once this has loaded, scroll down on the list of applications you have installed on your PC and look for 'Java'.  If it is showing JDK (Java development Kit), you need to delete/uninstall this and download the newest version of JRE (Java Runtime Environment) which can be found on oracles website If you have both, Uninstall the JDK and keep the JRE installed on your PC.

 

Screenshot 2023-11-15 212755.jpg

 

Once gone through all of the installation process of JRE, you can now relaunch the Simplicity PS launcher and it should load you straight into the game. 

 

client is stuck on error connecting/retrying infinite times
 

The first thing to try to fix this issue is deleting the cache then reopening the client to make sure the cache is downloaded properly. If your still having this issue  check your java versions if you have jdk and need it follow the pathing above if not you can remove jdk and install jre. These two fixes are normally the cause of this issue. if neither of these work please follow this guide for the ticket system and well help further with this issue  

 

 

NOTE: If you experience any Client related problems and none of the solutions worked do contact a staff member by creating a general ticket on our Discord. Click on the channel called '#Rules-read=me' and click on the tick after you have read it.  Then scroll down and under 'Information" click on '#support'.  React by clicking 'General Support" and your Support ticket will appear at the top of all the Channels (Top Left).

 

  • Like 2

Share this post


Link to post
Sign in to follow this  

DOWNLOAD & PLAY
FOR FREE TODAY!

play now
×
×
  • Create New...